Paul's RX-5

For you to showcase what you've done to your car and give other members ideas and inspiration.
User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Fri Apr 10, 2020 10:17 pm

Struggling to find a yellow bulb. Plenty of Amber bulbs.
It's a w21w capless bulb

User avatar
ChrisHolmes
Committee Member
Committee Member
Posts: 17854
Joined: Sun Jan 29, 2006 10:04 pm
RX-8: 231
Colour: Velocity Red
Location: Cheltenham
Has thanked: 4647 times
Been thanked: 1959 times

Re: Paul's RX-5

Post by ChrisHolmes » Fri Apr 10, 2020 10:46 pm

How about painting a clear bulb with yellow headlight lens paint.
Bridge Ported 231
Light weight Flywheel
Tein MonoSports with EDFC Active
Racing Beat F&R ARBs
Racing Brake 4 Pot Front Calipers
Racing Brake two piece slotted & drilled discs
LED Rear Lights
LED 3rd Brake light with blink effect
MazdaSpeed sills
Safety Devices Full cage
Royal Steering wheel
Short shifter
Mishimoto Catch Tank

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sat Apr 11, 2020 10:20 am

Something I'm exploring

User avatar
warpc0il
Spin Doctor
Spin Doctor
Posts: 24192
Joined: Sat Sep 06, 2008 10:56 pm
RX-8: 231
Colour: Lightning Yellow
Location: Groomsport, Co Down, NI
Has thanked: 386 times
Been thanked: 1484 times
Contact:

Re: Paul's RX-5

Post by warpc0il » Sat Apr 11, 2020 11:14 am

Yellow headlight paint is designed to go on on the lense not the bulb.

However the indicators only have a 50% duty cycle, for short periods, so you might get away with it.

It should stay on long enough to see what difference it makes anyway.

Sent from my SM-G800F using Tapatalk

Dave
The Spin Doctor ™
uǝǝɹɔs ɹnoʎ ʇɹǝʌuı ǝsɐǝld :ɹoɹɹǝ

User avatar
ChrisHolmes
Committee Member
Committee Member
Posts: 17854
Joined: Sun Jan 29, 2006 10:04 pm
RX-8: 231
Colour: Velocity Red
Location: Cheltenham
Has thanked: 4647 times
Been thanked: 1959 times

Re: Paul's RX-5

Post by ChrisHolmes » Sat Apr 11, 2020 12:30 pm

I had that thought when I had the idea and decided as you did Dave that at 50% cycle it may just work.
Look what I found! Paul please PM me your address and I will get it in the post to you.
Attachments
image.jpg
Bridge Ported 231
Light weight Flywheel
Tein MonoSports with EDFC Active
Racing Beat F&R ARBs
Racing Brake 4 Pot Front Calipers
Racing Brake two piece slotted & drilled discs
LED Rear Lights
LED 3rd Brake light with blink effect
MazdaSpeed sills
Safety Devices Full cage
Royal Steering wheel
Short shifter
Mishimoto Catch Tank

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sat Apr 18, 2020 7:52 pm

I ended up stripping the tint spray off the light unit today as it was the one I messed up. Just a comparison photo for you
Attachments
20200418_185606.jpg

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sun Apr 19, 2020 9:16 pm

I keep getting a code pop up on the abs module. B1318 - battery voltage is too low.
It gets its feed straight from the fuse and ignition switch.

Any ideas? Is it a known fault?

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sun Apr 19, 2020 9:27 pm

That might explain a few issues?

Split o-ring... Que a few jokes from a certain someone
Attachments
20200419_212627.jpg
20200419_212623.jpg

User avatar
warpc0il
Spin Doctor
Spin Doctor
Posts: 24192
Joined: Sat Sep 06, 2008 10:56 pm
RX-8: 231
Colour: Lightning Yellow
Location: Groomsport, Co Down, NI
Has thanked: 386 times
Been thanked: 1484 times
Contact:

Re: Paul's RX-5

Post by warpc0il » Sun Apr 19, 2020 10:08 pm

Not an unusual problem and can cause a variety of symptoms.

Often in conjunction with a split screw hole in the housing from over-tightening

Sent from my SM-G800F using Tapatalk

Dave
The Spin Doctor ™
uǝǝɹɔs ɹnoʎ ʇɹǝʌuı ǝsɐǝld :ɹoɹɹǝ

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sun Apr 19, 2020 10:21 pm

warpc0il wrote:
Sun Apr 19, 2020 10:08 pm
Not an unusual problem and can cause a variety of symptoms.

Often in conjunction with a split screw hole in the housing from over-tightening

Sent from my SM-G800F using Tapatalk
I've got the maf tube off the racing beat airbox

Scotty PZ
Club Member
Club Member
Posts: 199
Joined: Sun Oct 28, 2018 7:21 pm
RX-8: PZ
Colour: Galaxy Grey
Location: West Sussex
Has thanked: 47 times
Been thanked: 35 times

Re: Paul's RX-5

Post by Scotty PZ » Sun Apr 19, 2020 10:33 pm

The taillights look good, which spray did you use?
Galaxy Grey PZ number 24.
Large street port. Lots of flames, lots of smiles.

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sun Apr 19, 2020 10:53 pm

E-Tech Tint spray
These users thanked the author Paul_13 for the post:
Scotty PZ (Sun Apr 19, 2020 10:55 pm)

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Fri May 22, 2020 10:38 pm

I've done a few jobs since updating last. Swapped the front arb to mx5 item (from rx8 yellow dot) handles awesome now.
But the front now has a slight rattle...
Removed the coils and checked them over, turned out some moisture had gotten between the coil and bracket. Might explain the odd misfire
20200515_205133.jpg
20200515_205108.jpg
Cleaned that up and it idles nicer.

Now I keep having issues where I get completely power loss for a split second.
4 thoughts :
Air leak from intake boots /elbows
Throttle body failure
Throttle pedal failure
EGI relay failure

I've got a replacement intake boot, relay (thanks Rafael) and throttle pedal on the way.
I had an issue where the shuttle panel gasket was letting in water and completely fried my OBD adapter. I'm wondering if it managed to get into the throttle pedal. But I've taken it apart and I'm struggling to see how the thing actually works. Not the typical arrangement I'm used to seeing
IMG-20200522-WA0026.jpeg
Has anyone any idea how these function or what the failure symptoms are?

Just to mention also that the revs drop completely when this happens. The speed remains the same but the revs drop to zero and then jump back up

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Fri May 22, 2020 11:01 pm

Just did a obd scan with forscan and it's returned the following codes
Screenshot_20200522-225630_FORScan Lite.jpg

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Fri May 22, 2020 11:03 pm

Send as though the Canbus network is dropping out.
My guess is the EGI relay is failing causing the ecu to lose power momentarily

User avatar
boosted
Club Member
Club Member
Posts: 2776
Joined: Tue Jul 26, 2016 4:32 pm
RX-8: 231
Colour: Aurora Blue Mica
Location: Westbury Wilts
Has thanked: 74 times
Been thanked: 385 times

Re: Paul's RX-5

Post by boosted » Sat May 23, 2020 5:18 pm

There are multiple lives and earths on the pcm Paul...i think if you lost the egi relay youd have a significant jolt of power loss and multiple codes. My throttle cut issue was a blimin hard to find but simple loose earth.
I think its time to verify every earth and live.
The canbus wiring too. The twisted blue and white wiring...there is multiple crimp connections buried in the loom. If 1 of those is bad this could be giving you your intermitent fault.
Its gonna be a simple fix but finding it is gonna be painful part.
Could also be the pcm itself ive got the spare still if you want to try. Its the new owner of westy now but hes letting me keep for a little project that ground to a halt due to covid 19.

Sent from my SM-N950F using Tapatalk

231 streetported Rx8 renny powered Westfield kit race car.
92 Rx7 fd3s stock twins..est.320bhp. Track car.

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sat May 23, 2020 9:00 pm

Thanks boosted.

I read on rx8oc.com that if the abs voltage drops, it causes the problem with the Canbus wiring.
May have to check the wiring as I altered it to relocate the abs pump

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sat May 23, 2020 9:04 pm

When the car loses power, it is a massive jolt.
Then all the Canbus codes come up

User avatar
warpc0il
Spin Doctor
Spin Doctor
Posts: 24192
Joined: Sat Sep 06, 2008 10:56 pm
RX-8: 231
Colour: Lightning Yellow
Location: Groomsport, Co Down, NI
Has thanked: 386 times
Been thanked: 1484 times
Contact:

Re: Paul's RX-5

Post by warpc0il » Sat May 23, 2020 11:02 pm

A loose battery connection, damaged battery (internal fault) or corroded main body earth, could all qualify as the root cause for these latest issues.
Dave
The Spin Doctor ™
uǝǝɹɔs ɹnoʎ ʇɹǝʌuı ǝsɐǝld :ɹoɹɹǝ

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sun May 24, 2020 7:16 pm

Where does the rx8 battery earth as standard?

User avatar
Vj4sothername
Club Member
Club Member
Posts: 1717
Joined: Fri Sep 06, 2019 6:40 pm
RX-8: 231
Colour: Brilliant Black
Location: Oxford
Has thanked: 641 times
Been thanked: 146 times

Re: Paul's RX-5

Post by Vj4sothername » Sun May 24, 2020 7:25 pm

support bar under/between the airbox and battery.

Engine to body near the driver shock

Then one down near the Aircon and bell housing if I remember correctly.

These are the ones I found taking the engine out.
S1 - 231 - brilliant black
Feb 08 built,
Fake Toyosport back box,
Dents,
Scratches,
Replacement engine,
Smiles

User avatar
boosted
Club Member
Club Member
Posts: 2776
Joined: Tue Jul 26, 2016 4:32 pm
RX-8: 231
Colour: Aurora Blue Mica
Location: Westbury Wilts
Has thanked: 74 times
Been thanked: 385 times

Re: Paul's RX-5

Post by boosted » Sun May 24, 2020 7:33 pm

Also a big 1 earth connection on ppf.
I always like to run extras too.

Sent from my SM-N950F using Tapatalk

231 streetported Rx8 renny powered Westfield kit race car.
92 Rx7 fd3s stock twins..est.320bhp. Track car.

User avatar
Vj4sothername
Club Member
Club Member
Posts: 1717
Joined: Fri Sep 06, 2019 6:40 pm
RX-8: 231
Colour: Brilliant Black
Location: Oxford
Has thanked: 641 times
Been thanked: 146 times

Re: Paul's RX-5

Post by Vj4sothername » Sun May 24, 2020 7:35 pm

boosted wrote:Also a big 1 earth connection on ppf.
I always like to run extras too.

Sent from my SM-N950F using Tapatalk
Really!? I didn't find that when I took mine of the other day. Image
S1 - 231 - brilliant black
Feb 08 built,
Fake Toyosport back box,
Dents,
Scratches,
Replacement engine,
Smiles

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sun May 24, 2020 9:26 pm

I've run an earth from the negative terminal to the inlet.
Inlet to body.
Body to earth point on wings.
Negative terminal to common earth point on slam panel.
Slam panel to cross member (standard earth point)
Slam panel to coil bracket and throttle body.
Main earth cable from wiring loom.

I've already gone over the top on earth points which is having me stumped.
20200524_212239.jpg
20200524_212612.jpg
20200524_212624.jpg

User avatar
Paul_13
Club Member
Club Member
Posts: 679
Joined: Sat Jul 27, 2019 1:53 pm
RX-8: 231
Location: Basingstoke
Has thanked: 71 times
Been thanked: 101 times

Re: Paul's RX-5

Post by Paul_13 » Sun May 24, 2020 9:30 pm

Just a thought, but when I turn my fog lights on, the headlights dim slightly. Likewise if I beep the horn with the lights on.
If I've got my sub running loud, the voltage on the stereo drops to 13v minimum.
Battery is new.
I'm wondering if the alternator is on the blink

Post Reply

Return to “Personal Car Projects and Mods”